Installing Nextcloud on Ubuntu 16.04 LTS with Redis, APCu, SSL & Apache

Sorry… :blush::blush::blush:
Error log

OK thanks, do you have the one that doesn’t end in a number?

Of course, here it is:

Error log

Ok so I see a couple of errors but nothing that immediately jumps at me. Can you restart Apache, replicate the issue a few times and then re-submit the error.log please?

1 Like

Good morning Jason!
Thank you so much for this first glance.
Of course I will, I hope to succeed today.
Thanks again and have a nice day!

Good morning Jason :slight_smile:
So I tried again and here is the new error log:
error log new
One thing: before I could access my Nextcloud from the web while not being able to make any changes, today, after configuring redis, I could not even see the initial screen of Nextcloud, while not giving me any error …

Sorry for the delay, I didn’t see a notification you’d responded!
I checked your error, and it all seems to point back to Redis erroring. Are you able to see if it’s running?

sudo service redis status

Also validate you followed that part of my guide correctly please?

Not being able to change things (files & folders?) sounds like a permissions issue. Who owns your Nextcloud install directory?

sudo ls -l /var/www/html/...

And your data directory?

sudo ls -l /path/to/data/

1 Like

Hi Jason,
no problem and thanks again for your patience! :slight_smile:
So yes, I followed your guide faithfully.

Irisultati of the commands you told me to do, I do not know how to show them: the fourm does not make me send posts with links … :frowning:

Sorry about that, I’ve adjusted your account to theoretically allow links.

You need command line access to your server, then you can run those commands.

sudo ls -l /var/www/html
sudo ls -l /var/www/html/nextcloud

sudo ls -l /var/www/html/nextcloud/data/

That’ll allow me to check the permissions on your install.

1 Like

No problem! :slight_smile:
So, here are the results:

sudo ls -l /var/www/html

sudo ls -l /var/www/html/nextcloud

sudo service redis status

sudo ls -l /home/archivio/nextcloud/data/Orestis

Aside from it not necessarily being recommended you put anything under home that looks OK. So beyond the redis errors, were you seeing any others?

1 Like

Hi Jason, I did not understand: should I move all of NExtcloud (the one in / var / www / html / nextcloud) to the home folder?
Then, for the rest, I do not seem to have seen other errors.

No, don’t move anything to the home folder.
At this point without seeing your environment first hand I’m not sure what’s wrong, sorry.

You could maybe swap redis for aPCU in your config.php file and see if that resolves the black page, but that doesn’t fix redis itself.

https://docs.nextcloud.com/server/13/admin_manual/configuration_server/caching_configuration.html#id1

1 Like

Thank you very much and really for the patience you had! :slight_smile:
Yes, with APCu it works well, too bad that it does not have the same performance as Redis, but, in fact, it’s not a big deal in the end.
Thanks again and I wish you a good job! :slight_smile:

Renzo

Keep an eye on your redis logs, and perhaps it’ll become clear why redis is bombing out, at least you’ve a working site for now :+1:

1 Like

Without a doubt, in the meantime I can work a little better! :+1:
Who knows what I will have combined, so as not to make Redis work!:joy:
Thanks again and happy Sunday!:grinning:

after all
How To install collabora online with an existing nextcloud on domain ?

Have a look for guides over on help.nextcloud.com :slight_smile:

Thank you for this guide.
Greatly appreciated.
I am trying to install NC on a UDOO X86 SBC running openSUSE Leap 15.
I have followed SDB:Nextcloud - openSUSE Wiki
and installed NC and am able to login.
The purpose of the Nextcloud installation is to be able to store photos and videos from our devices inside our house. What I don’t know is how to setup Let’s Encrypt, because NC is running locally and not on a domain name. So instead of nc.domain.org , what should I put?
sudo ./certbot-auto --apache --agree-tos --rsa-key-size 4096 --email user@domain.org --redirect -d nc.domain.org

This is what I get at the NC’s settings page:

Security & setup warnings

It’s important for the security and performance of your instance that everything is configured correctly. To help you with that we are doing some automatic checks. Please see the Tips & Tricks section and the documentation for more information.

  • Accessing site insecurely via HTTP. You are strongly adviced to set up your server to require HTTPS instead, as described in the [security tips].

  • Your web server is not properly set up to resolve “/.well-known/caldav”. Further information can be found in the [documentation].

  • Your web server is not properly set up to resolve “/.well-known/carddav”. Further information can be found in the [documentation].

  • No memory cache has been configured. To enhance performance, please configure a memcache, if available. Further information can be found in the [documentation]

  • The PHP OPcache is not properly configured. [For better performance it is recommended]to use the following settings in the php.ini :

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

Would apreciate any help.

Regards,
Kourosh

Hey @Simorgh

You can’t LE an internal host, it requires a public domain name.
The closest I guess you’d get would be a self-signed cert but you’ll still get warnings on this.