Installing Nextcloud on Ubuntu 16.04 LTS with Redis, APCu, SSL & Apache


(Stephen Kwabena) #21
[Thu Aug 02 23:31:13.573288 2018] [mpm_event:notice] [pid 2103:tid 140713619969920] AH00489: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:31:13.573432 2018] [core:notice] [pid 2103:tid 140713619969920] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:38:35.535094 2018] [mpm_event:notice] [pid 2103:tid 140713619969920] AH00491: caught SIGTERM, shutting down
[Thu Aug 02 23:38:36.626152 2018] [mpm_prefork:notice] [pid 12325] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:38:36.626279 2018] [core:notice] [pid 12325] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:38:38.160321 2018] [mpm_prefork:notice] [pid 12325] AH00169: caught SIGTERM, shutting down
[Thu Aug 02 23:38:39.338805 2018] [mpm_prefork:notice] [pid 12437] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:38:39.338950 2018] [core:notice] [pid 12437] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:42:05.639492 2018] [mpm_prefork:notice] [pid 12437] AH00169: caught SIGTERM, shutting down
[Thu Aug 02 23:42:06.749840 2018] [mpm_prefork:notice] [pid 29114] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:42:06.749962 2018] [core:notice] [pid 29114] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:46:44.526633 2018] [mpm_prefork:notice] [pid 29114] AH00169: caught SIGTERM, shutting down
[Thu Aug 02 23:46:45.647659 2018] [mpm_prefork:notice] [pid 29444] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:46:45.647787 2018] [core:notice] [pid 29444] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:50:46.404076 2018] [mpm_prefork:notice] [pid 29444] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 02 23:50:46.492171 2018] [mpm_prefork:notice] [pid 29444] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:50:46.492196 2018] [core:notice] [pid 29444] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:51:18.525482 2018] [mpm_prefork:notice] [pid 29444] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 02 23:51:18.661950 2018] [mpm_prefork:notice] [pid 29444] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:51:18.662079 2018] [core:notice] [pid 29444] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:51:18.962095 2018] [mpm_prefork:notice] [pid 29444] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 02 23:51:19.061525 2018] [mpm_prefork:notice] [pid 29444] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:51:19.061564 2018] [core:notice] [pid 29444] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:51:25.153263 2018] [mpm_prefork:notice] [pid 29444] AH00169: caught SIGTERM, shutting down
[Thu Aug 02 23:51:26.277283 2018] [mpm_prefork:notice] [pid 6821] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:51:26.277404 2018] [core:notice] [pid 6821] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 02 23:52:13.235401 2018] [mpm_prefork:notice] [pid 6821] AH00169: caught SIGTERM, shutting down
[Thu Aug 02 23:52:14.358482 2018] [mpm_prefork:notice] [pid 6880] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Aug 02 23:52:14.358603 2018] [core:notice] [pid 6880] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:39:43.170675 2018] [mpm_prefork:notice] [pid 6880] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 00:39:43.280716 2018] [mpm_prefork:notice] [pid 6880] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Fri Aug 03 00:39:43.280747 2018] [core:notice] [pid 6880] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:39:47.160491 2018] [mpm_prefork:notice] [pid 6880] AH00169: caught SIGTERM, shutting down
[Fri Aug 03 00:39:51.475436 2018] [mpm_prefork:notice] [pid 13308] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Fri Aug 03 00:39:51.475552 2018] [core:notice] [pid 13308] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:40:55.328457 2018] [php7:warn] [pid 13313] [client 67.205.29.157:42438] PHP Warning:  mysqli_connect(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in /var/www/sms/conection/connect.php on line 3
[Fri Aug 03 00:45:07.172677 2018] [mpm_prefork:notice] [pid 13308] AH00169: caught SIGTERM, shutting down
[Fri Aug 03 00:46:22.653420 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Fri Aug 03 00:46:22.674230 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:54:31.351083 2018] [mpm_prefork:notice] [pid 1165] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 00:54:31.582531 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Fri Aug 03 00:54:31.582562 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:54:38.345106 2018] [mpm_prefork:notice] [pid 1165] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 00:54:38.482153 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Fri Aug 03 00:54:38.482197 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:54:47.237214 2018] [mpm_prefork:notice] [pid 1165] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 00:54:47.361130 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 00:54:47.361150 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 00:54:47.566026 2018] [mpm_prefork:notice] [pid 1165] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 00:54:47.714215 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 00:54:47.714242 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:06:07.544649 2018] [mpm_prefork:notice] [pid 1165] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:06:07.669976 2018] [mpm_prefork:notice] [pid 1165] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:06:07.670006 2018] [core:notice] [pid 1165] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:06:11.353952 2018] [mpm_prefork:notice] [pid 1165] AH00169: caught SIGTERM, shutting down
[Fri Aug 03 01:06:15.612129 2018] [mpm_prefork:notice] [pid 8605] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:06:15.612245 2018] [core:notice] [pid 8605] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:06:52.908263 2018] [mpm_prefork:notice] [pid 8605] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:06:53.005166 2018] [mpm_prefork:notice] [pid 8605] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:06:53.005203 2018] [core:notice] [pid 8605] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:06:59.832345 2018] [mpm_prefork:notice] [pid 8605] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:06:59.971718 2018] [mpm_prefork:notice] [pid 8605] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:06:59.971750 2018] [core:notice] [pid 8605] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:07:07.039235 2018] [mpm_prefork:notice] [pid 8605] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:07:07.156347 2018] [mpm_prefork:notice] [pid 8605] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:07:07.156366 2018] [core:notice] [pid 8605] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:07:07.321930 2018] [mpm_prefork:notice] [pid 8605] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:07:07.450266 2018] [mpm_prefork:notice] [pid 8605] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:07:07.450292 2018] [core:notice] [pid 8605] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:07:32.836338 2018] [rewrite:error] [pid 8877] [client 197.251.240.51:52007] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:13:06.626423 2018] [mpm_prefork:notice] [pid 8605] AH00169: caught SIGTERM, shutting down
[Fri Aug 03 01:13:07.782861 2018] [mpm_prefork:notice] [pid 10491] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:13:07.782970 2018] [core:notice] [pid 10491] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:13:32.077554 2018] [rewrite:error] [pid 10494] [client 197.251.240.51:56246] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:13:54.839252 2018] [rewrite:error] [pid 10495] [client 197.251.240.51:32934] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:13:56.598741 2018] [rewrite:error] [pid 10498] [client 197.251.240.51:62225] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/favicon.ico
[Fri Aug 03 01:13:57.837424 2018] [rewrite:error] [pid 10495] [client 197.251.240.51:32934] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:13:58.208188 2018] [rewrite:error] [pid 10498] [client 197.251.240.51:62225] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/favicon.ico
[Fri Aug 03 01:13:59.448123 2018] [rewrite:error] [pid 10495] [client 197.251.240.51:32934] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:14:28.919209 2018] [rewrite:error] [pid 10509] [client 197.251.240.51:42115] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:14:31.759318 2018] [rewrite:error] [pid 10509] [client 197.251.240.51:42115] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:14:33.756038 2018] [rewrite:error] [pid 10509] [client 197.251.240.51:42115] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:31:58.453510 2018] [mpm_prefork:notice] [pid 10491] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 03 01:31:58.578263 2018] [mpm_prefork:notice] [pid 10491] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Fri Aug 03 01:31:58.578290 2018] [core:notice] [pid 10491] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 03 01:33:11.565506 2018] [rewrite:error] [pid 11073] [client 41.66.199.137:41570] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:33:14.696978 2018] [rewrite:error] [pid 11074] [client 41.66.199.137:59208] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:33:20.146419 2018] [rewrite:error] [pid 11075] [client 41.66.199.137:41629] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/
[Fri Aug 03 01:33:34.895938 2018] [rewrite:error] [pid 11076] [client 41.66.199.137:47402] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/owncloud/

(Jason Bayton) #22

There’s the problem. There’s a misconfiguration either on your Apache conf file, or one of your Apache vhost configurations.

What do you see if you ls -l /etc/apache2/sites-enabled?


(Stephen Kwabena) #23
lrwxrwxrwx 1 root root 35 Aug  3 12:17 000-default.conf -> ../sites-available/000-default.conf
lrwxrwxrwx 1 root root 59 Aug  3 14:57 demo.bbfnungua.org-le-ssl.conf -> /etc/apache2/sites-available/demo.bbfnungua.org-le-ssl.conf
lrwxrwxrwx 1 root root 52 Aug  3 14:43 demo.bbfnungua.org.conf -> /etc/apache2/sites-available/demo.bbfnungua.org.conf
lrwxrwxrwx 1 root root 61 Aug  4 02:32 sdrive.bbfnungua.org-le-ssl.conf -> /etc/apache2/sites-available/sdrive.bbfnungua.org-le-ssl.conf
lrwxrwxrwx 1 root root 54 Aug  4 02:31 sdrive.bbfnungua.org.conf -> /etc/apache2/sites-available/sdrive.bbfnungua.org.conf

(Jason Bayton) #24

One of those demo/sdrive configs is overriding your NC install. I don’t see a nextcloud.conf vhost there either so I really can’t say how you’ve set it up.


(Stephen Kwabena) #25

So it means I should have only one Vhost on my server or…?


(Jason Bayton) #26

No not at all, it means every vhost needs to be unique if it is to work with other vhosts on your server.

If two enabled vhosts both point to /var/www/html then they’ll clash. Whilst one pointing to /var/www/html/server1/ and the other /var/www/html/server2/ will work fine together.


(Stephen Kwabena) #27

Yes That’s what I have done. They all have unique directory and unique subdomain names


(Jason Bayton) #28

One of them will be clashing with the one you’ve created for Nextcloud, otherwise Nextcloud would be running OK. Specifically, I imagine something for /var/www/ has the settings FollowSymLinks and SymLinksIfOwnerMatch disabled.


(Stephen Kwabena) #29

So how will I enable them?


(Jason Bayton) #30

Look through your vhost conf files to see where the above has been set. If you don’t find these items, check your main apache.conf file /etc/apache2/apache2.conf and see what’s set there against /var/www/


(Stephen Kwabena) #31

Ok a minute let me do that now


(Stephen Kwabena) #32
<Directory />
	Options FollowSymLinks
	AllowOverride None
	Require all denied
</Directory>

<Directory /usr/share>
	AllowOverride None
	Require all granted
</Directory>

<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride All
	Require all granted
</Directory>

(Jason Bayton) #33

Then this is overridden either at the vhost level or with a .htaccess file.


(Stephen Kwabena) #34

So please what should I do now?


(Stephen Kwabena) #36

Fixed by not allowing override in the apache.conf file.


(NNextcloudde) #37

Hello,
I’m sorry if I bother you and I’m sorry for my lack of competence!
I ask you please, help with configuring the memcache:
I have a Nextcloud Box, which is a Raspberry Pi Model B, Ubuntu 18.04.1 version for Raspberry, apache2, php7.2, mariadb.
I followed your guide to setting up the memache step by step, but I have a problem: I regularly log in to my Nextcloud both locally and remotely and the memcache warning is gone, but I can not load anything nor Effective changes.
Where am I wrong?
Thank you for your patience! :blush:


(Jason Bayton) #38

I’d be happy to help, but I think I need a more in-depth description of what’s happening, and if you can find anything in your nextcloud or apache logs I’d be able to analyse.


(NNextcloudde) #39

Hello, you’re kind, thank you! :slight_smile:
As I said, I followed step by step your guide to configure the memcache, I finish all operations, I normally log in to my Nextcloud through the browser, I no longer see the alliges regarding the memcache configuration, but I can not load any file nor, for example, to create a folder.
How can I attach the apache and / or nextcloud logs here?
Thanks again!


(Jason Bayton) #40

A post was merged into an existing topic: Experimenting with clustering and data replication in Nextcloud with MariaDB Galera and SyncThing


(Jason Bayton) #41

Copy and paste them, if you do three backticks (`) on the lines above and below the logs they’ll format fine also.